Announcement

Collapse
No announcement yet.

*ACCESS DENIED* 5th Generation 4Runner

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • *ACCESS DENIED* 5th Generation 4Runner


    ***ISSUE HAS BEEN RESOLVED - TURN YOUR BLOWER OFF***


    Hello all, more progress has been made on tuning the bad 2015 4runner, but I have encounter another problem which I wanted to generally ask. I have had to update my ECU to 335E3200 from 335E3000. It was a brutal process through techstream but I have learned so much. Now that my ECU is updated, VF tuner recognizes it as well. The software seems to prepare the ECU much better. I have unlocked the 335E3200 file and removed some DTC's. I cannot save it however, and if I export it, I cannot put it in the 09+ 4Runners folder. It says I do not have access. I saved it on my desktop and proceeded to go back, prepare the ECU with the selected calibration file, and ReCalibrate. This is what the log shows :

    Battery Voltage: 12.875
    VIN: JTE-------------- ( I removed part of this for safety Reasons)
    ID: 335E3200
    CAN Timeout: 4ms
    Connection to ECU is reliable. DO NOT ATTEMPT TO FLASH YOUR VEHICLE IF BATTERY VOLTAGE IS UNDER 12.0 VOLTS!
    Start flashing... DO NOT DISCONNECT OT PRESS ANY BUTTONS
    CallibrationID: 335E3200
    ECM 992kb GEN1 Version 2
    KEY sent
    KEY authorization success


    ----------------------------------------------------------------------------------

    Although it says KEY authorization success, it proceeds to say "COMMUNICATION / ECM Error ERROR UNLOCK INVALID" . Am I selecting and saving these files to the wrong place? Any help would be great.
    Last edited by Robaholic; 07-11-2021, 11:21 PM.

  • #2
    Originally posted by Robaholic View Post
    Hello all, more progress has been made on tuning the bad 2015 4runner, but I have encounter another problem which I wanted to generally ask. I have had to update my ECU to 335E3200 from 335E3000. It was a brutal process through techstream but I have learned so much. Now that my ECU is updated, VF tuner recognizes it as well. The software seems to prepare the ECU much better. I have unlocked the 335E3200 file and removed some DTC's. I cannot save it however, and if I export it, I cannot put it in the 09+ 4Runners folder. It says I do not have access. I saved it on my desktop and proceeded to go back, prepare the ECU with the selected calibration file, and ReCalibrate. This is what the log shows :

    Battery Voltage: 12.875
    VIN: JTE-------------- ( I removed part of this for safety Reasons)
    ID: 335E3200
    CAN Timeout: 4ms
    Connection to ECU is reliable. DO NOT ATTEMPT TO FLASH YOUR VEHICLE IF BATTERY VOLTAGE IS UNDER 12.0 VOLTS!
    Start flashing... DO NOT DISCONNECT OT PRESS ANY BUTTONS
    CallibrationID: 335E3200
    ECM 992kb GEN1 Version 2
    KEY sent
    KEY authorization success


    ----------------------------------------------------------------------------------

    Although it says KEY authorization success, it proceeds to say "COMMUNICATION / ECM Error ERROR UNLOCK INVALID" . Am I selecting and saving these files to the wrong place? Any help would be great.
    Because you updated recently with Techstream. It counts it as an ECU flash. Gen1 ECUs make you wait between flashes. I'd drive it around, wait a day I suppose.

    Whenever I've updated 4runners, I've then had to wait until the next day to tune

    Comment


    • Robaholic
      Robaholic commented
      Editing a comment
      ***UPDATE**** Yes that may have been the case, although I honestly think I left my blower on when I did it. Once it was turned off I accidently flashed the ECU and it WORKED! I guess the lesson is do not have your blower on!

  • #3
    Interesting. Thank you for the update on it. If I understand right the vehicle was denying a flash due to the A/C blower on, and after shutting it off the problem resolved.


    What year is your 4Runner?

    Comment


    • Robaholic
      Robaholic commented
      Editing a comment
      2015 SR5. I had recalibrated my ECU from I think E3000 to E3200 through techstream, it had been about an hour after I updated the ECU that I attempted the tune. I attempted 2-3 times before going back on the forums and watching one of the youtube videos yall have posted about tuning a Scion, and I heard him mention to make sure your blower was off. So I did indeed (I actually flashed it with 11.9V because I didn't think it was going to work) but it did! I have been exploring VFTuner since!!!!! Someone did comment that it can take time after your ECU gets recalibrated although I am still not sure if that was the case or if it was the blower due to how instantly it flashed once the blower was off. Hope that Helps!

    • tonered
      tonered commented
      Editing a comment
      I really need to remember that blower trick.

  • #4
    I tried this blower trick today and didn’t work for me. Did TSB update with TS. He Took it for a 20 min drive around town. Came back and I Unlocked the vin and tried flashing and it didn’t take. Made sure and double checked that the blower was off along with all other accessories. Tried again and still didn’t take. I will be trying tomorrow.

    Anyone know the proper steps or process of flashing with tsb? It’s a 2011 updated to 35b11

    Comment


    • Robaholic
      Robaholic commented
      Editing a comment
      As long as the Calibration ID is the same as the tune file, then you may just have to wait an hour. When I first update and recalibrated my ECU it was giving me some issues, which I have determined were the Blower, but quite frankly I could be very wrong. I continued to get to the Authorization Step and thats when it would boot me out for some reason. Every now and then it will boot me out for no reason when I am attempting to flash, and I just have exit the flashing window (not the software) and reconnect to the ECU. Sometimes it takes two or three tries before it lets me back in. Maybe just be patient and keep trying? Once your ECU is Re-Calibrated, the last step should be to tune and flash. You can hit the flash button up on the top row, select Prepare ECU, and then select your Calibration File. I sometimes select the calibration file first before preparing the ECU but im not sure that it matters. Then select Calibrate ECM and go HAMMM. That is the process I use in VF After re-calibrating the ECU and it seems to work most of the time.

  • #5
    Originally posted by Jnieva007 View Post
    I tried this blower trick today and didn’t work for me. Did TSB update with TS. He Took it for a 20 min drive around town. Came back and I Unlocked the vin and tried flashing and it didn’t take. Made sure and double checked that the blower was off along with all other accessories. Tried again and still didn’t take. I will be trying tomorrow.

    Anyone know the proper steps or process of flashing with tsb? It’s a 2011 updated to 35b11
    There are ECU Update Instructions in the Help menu.

    Sorry that the blower trick didn't work.
    2017 ACLB Sport 6MT BR - 04B14 Ultimate Test Tune on 92
    TSB PDFs are at nhtsa.gov / Click on Recalls, search by make and model (not VIN), and then click on Manufacturer Communications
    Latest vF Version Download

    Comment


    • #6
      Tried flashing today. Didn’t work…ecu Id file matches too. Not sure what to do

      Comment


      • Robaholic
        Robaholic commented
        Editing a comment
        I'm sorry to hear. Make sure your key is ALL the way on right before the start, not just one click over. I know the battery will turn on but most engine lights and dash lights done come on. Those dash lights need to be on. I hope you figure it out! tonered is a great administrator and he should take great care of you.

      • tonered
        tonered commented
        Editing a comment
        Thanks, but this is either the flash lockout thing or a job for VFTuner .

        Please post up screenshots.

    • #7
      Originally posted by Jnieva007 View Post
      Tried flashing today. Didn’t work…ecu Id file matches too. Not sure what to do
      It sounds like it is time for a Zendesk ticket to get VFTuner 's help. Sorry!
      2017 ACLB Sport 6MT BR - 04B14 Ultimate Test Tune on 92
      TSB PDFs are at nhtsa.gov / Click on Recalls, search by make and model (not VIN), and then click on Manufacturer Communications
      Latest vF Version Download

      Comment


      • #8
        Please see here regarding any error / unlock invalids
        https://forum.vftuner.com/forum/main...icles#post5730

        Comment


        • #9
          Just tried with 1.3.1.2. Had gen1 box checked, prepared ecu. Then attempted to flash. Still got the error. I ran it multiple times making sure I followed the written directions. Ecu didn’t take. Replied and sent photo to existing ticket. Hopefully it’s an easy fix.

          Comment


          • #10
            Originally posted by Jnieva007 View Post
            Just tried with 1.3.1.2. Had gen1 box checked, prepared ecu. Then attempted to flash. Still got the error. I ran it multiple times making sure I followed the written directions. Ecu didn’t take. Replied and sent photo to existing ticket. Hopefully it’s an easy fix.
            try it without it checked

            Comment


            • #11
              Originally posted by VFTuner View Post

              try it without it checked
              I have also tried that. The ECU didn't take and same pop up direction shows.

              Comment


              • #12
                Wanted to update. For some odd reason it took this time after many tries. Thanks you for your assistance 🤙🏽

                Comment

                Working...
                X